Intermittent Service Disruptions Affecting Zoom, Intercom, and Website Access

Incident Report for Outschool

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:21 PDT

Monitoring

We’re aware of intermittent issues and delays due to a third party vendor affecting parts of Outschool, including Zoom, Customer Support, and general website access.

Our team is monitoring the situation. Please email support@outschool.com if you’re having trouble, and we’ll follow up as soon as possible.
Posted Oct 20, 2025 - 09:37 PDT