Delayed Class Access due to Zoom Incident for some users

Incident Report for Outschool

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 06:46 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 04:43 PST

Identified

Zoom has reported an incident causing delays for some users attempting to join live Outschool classes. Zoom is currently investigating the issue, and we are monitoring updates.

If your learner missed a class due to this incident, please contact support@outschool.com for assistance
Posted Nov 18, 2025 - 19:25 PST