Completed -
The scheduled maintenance has been completed.
Mar 18, 22:00 PDT
In progress -
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 18, 19:00 PDT
Update -
We will be undergoing scheduled maintenance during this time.
Mar 18, 18:33 PDT
Scheduled -
We will be performing scheduled maintenance on March 18th from 7:00 PM to 9:00 PM PDT. During this time, classes will continue as usual, but certain account and enrollment management services may be temporarily unavailable as we enhance our platform.
For more details, please visit our support page.
Thank you for your patience and understanding.
Mar 18, 08:15 PDT