Teacher Payout Delay and Overpaid Funds

Incident Report for Outschool

Resolved

The issue causing a payment delay has been resolved, and payments are now processing as expected. The individual teacher stats page may not reflect this yet, but it will be updated in the future. We appreciate your patience!
Posted Feb 18, 2025 - 13:05 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2025 - 05:09 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 17, 2025 - 11:03 PST

Investigating

We are investigating an issue causing a delay in payment for some classes and a separate issue that resulted in overpayment to some teachers.

We apologize for the inconvenience. Our engineers are working to resolve this issue as soon as possible.

We will share updates here as soon as we have them.
Posted Feb 16, 2025 - 13:38 PST