Intermittent Customer Support Delays

Incident Report for Outschool

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 13:28 PST

Investigating

We’re currently experiencing intermittent issues and delays due to a third-party vendor, which may affect certain aspects of our Customer Support, including our Help Center and chat feature.

Our team is actively monitoring the situation. If you need assistance, please email support@outschool.com, and we’ll follow up as soon as possible.
Posted Jan 09, 2026 - 12:12 PST