Hotmail users unable to reply to support, messages marked 'Undeliverable'.

Incident Report for Outschool

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 12:12 PST

Identified

We are currently experiencing delivery issues with Hotmail email addresses. If you are contacting us from a Hotmail account and receive an “Undeliverable” message, please reach out to Support via the website chat messenger or use an alternate email address.
Posted Feb 24, 2026 - 08:29 PST
This incident affected: Outschool.com Website.