Delays with customer support chat and email responses
Incident Report for Outschool
Resolved
This incident has been resolved and we are now able to respond to your support chat and email inquiries. Thank you for patience!
Posted Oct 12, 2023 - 08:36 PDT
Identified
We are currently experiencing technical difficulties with responding to customer support chat and email inquiries, and response times may be delayed. We are continuing to investigate and will continue to post updates as we know more.
Posted Oct 12, 2023 - 07:49 PDT